Login Register Actian.com  

Actian Community Forum



Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 2009-06-15   #1 (permalink)
Junior Member
 
Join Date: May 2009
Posts: 9
Default Database connectivity problem from Talend/JasperSoft

I am trying to get the ingres connection from talend and jaspersoft.

URL - jdbc:ingres://localhost:II7/insurancedwh
Driver - com.ingres.jdbc.IngresDriver

but while i am testing the connection from talend.
ERROR msg -
com.ingres.gcf.util.SqlEx: User authorization check failed.
Your user identifier was not known to this installation.
Contact your system manager for further assistance.
at com.ingres.gcf.jdbc.DrvObj.readError(DrvObj.java:8 44)
at com.ingres.gcf.jdbc.DrvObj.readResults(DrvObj.java :630)
at com.ingres.gcf.jdbc.JdbcConn.connect(JdbcConn.java :521)
at com.ingres.gcf.jdbc.JdbcConn.<init>(JdbcConn.java: 329)
at com.ingres.gcf.jdbc.JdbcDrv.connect(JdbcDrv.java:5 91)
at java.sql.DriverManager.getConnection(DriverManager .java:525)
at java.sql.DriverManager.getConnection(DriverManager .java:171)
at insurancedemo_ingresv1.city_lookup_0_1.City_Lookup .tIngresInput_1Process(City_Lookup.java:508)


Thanks in advance
Lipika
lrout is offline   Reply With Quote
Old 2009-06-15   #2 (permalink)
Ingres Community
 
Join Date: Mar 2007
Location: Orpington, Kent, UK
Posts: 111
Default

Hi Lipika,

There are usually two reasons why you get that error:
  1. The authentication mechanism set-up has not been completed or
  2. The user connecting to the database is different to the user who owns the database.

You have not indicated what version or platform you are using.

On *nix take a look at http://docs.ingres.com/Ingres/9.2/Co...lnet.htm#o1204. You can check if authentication mechanism set-up has been completed by the existence of II_SHADOW_PWD in the Ingres symbol table.
On Windows ensure that the owner of the Ingres instance has to relevant rights enabled.

Check the owner of the database and the user that you are connecting with are both valid Ingres users. If you don't specify user and password credentials in the JDBC connection then the current user is assumed.
notnull is offline   Reply With Quote
Old 2009-06-15   #3 (permalink)
Ingres Community
 
daryl.monge@ingres.com's Avatar
 
Join Date: Mar 2007
Location: Naperville, IL
Posts: 300
Default

Newer versions of the DAS/JDBC system do not need the shadow password stuff set up anymore, which is really quite nice in "localhost" situations
daryl.monge@ingres.com is offline   Reply With Quote
Old 2009-06-22   #4 (permalink)
Junior Member
 
Join Date: May 2009
Posts: 9
Default

I am using Ingres 9.2.So i just disabled the password validation for the user "osic" from accessdb command and set it to "no".
And i was able to login to Ingres by using OS password for the user "osic".
Now i started the same Ingres instance with a different hostname,again i am facing the connection failed message from jaspersoft and talend.I dont see any log file in <ingres_home>/files/

I am already using the latest version of iijdbc.jar.

Talend is giving this error --->

###############################
Exception in component tIngresInput_2
com.ingres.gcf.util.SqlEx: Communications error while establishing connection.
at com.ingres.gcf.util.SqlEx.get(SqlEx.java:97)
at com.ingres.gcf.util.SqlEx.get(SqlEx.java:130)
at com.ingres.gcf.util.SqlEx.get(SqlEx.java:169)
at com.ingres.gcf.dam.MsgIo.<init>(MsgIo.java:274)
at com.ingres.gcf.dam.MsgOut.<init>(MsgOut.java:263)
at com.ingres.gcf.dam.MsgIn.<init>(MsgIn.java:307)
at com.ingres.gcf.dam.MsgConn.<init>(MsgConn.java:228 )
at com.ingres.gcf.jdbc.DrvConn.connect(DrvConn.java:6 43)
at com.ingres.gcf.jdbc.DrvConn.<init>(DrvConn.java:42 3)
at com.ingres.gcf.jdbc.JdbcDrv.connect(JdbcDrv.java:5 84)
at java.sql.DriverManager.getConnection(DriverManager .java:582)
at java.sql.DriverManager.getConnection(DriverManager .java:185)
################################################## ###########


Please help me out,i am kind of stucked.

Lipika

Last edited by lrout; 2009-06-23 at 01:30 AM.
lrout is offline   Reply With Quote
Old 2009-06-23   #5 (permalink)
Junior Member
 
Join Date: May 2009
Posts: 9
Default

These are the variables in the symbol table.Looks like ingres is not running on II7.

[osic@ec2-174-129-242-142:~] ingprenv
II_INSTALLATION=II
II_CONFIG=/opt/Ingres/IngresII/ingres/files
II_GCNII_LCL_VNODE=ec2-174-129-242-142.compute-1.amazonaws.com
II_DATABASE=/opt/Ingres/IngresII
II_CHECKPOINT=/opt/Ingres/IngresII
II_JOURNAL=/opt/Ingres/IngresII
II_DUMP=/opt/Ingres/IngresII
II_WORK=/opt/Ingres/IngresII
II_NUM_OF_PROCESSORS=2
II_MAX_SEM_LOOPS=2000
II_TIMEZONE_NAME=NA-PACIFIC
II_CHARSETII=ISO88591
II_TEMPORARY=/tmp
ING_EDIT=/usr/bin/vi
II_GCNII_PORT=42504
II_SHADOW_PWD=/opt/Ingres/IngresII/ingres/bin/ingvalidpw
ING_ABFDIR=/opt/Ingres/IngresII/ingres/abf
II_HOSTNAME=ec2-174-129-242-142.compute-1.amazonaws.com
II_GC_REMOTE=ON
lrout is offline   Reply With Quote
Old 2009-06-24   #6 (permalink)
Actian Corp
 
Bodo's Avatar
 
Join Date: Mar 2007
Location: On the OpenROAD
Posts: 2,168
Default

II7 is the default network protocol (tcp_ip) port of the DAS (Data Access Server) for an Ingres installation with II_INSTALLATION=II.
Check the $II_SYSTEM/ingres/files/errlog.log for startup messages from the DAS.
There should be messages like E_GC4803_NTWK_OPEN... (which contains the port number), E_GC4802_LOAD_CONFIG... and E_GC4800_STARTUP...

Have you tried to replace "localhost" in the URL with "127.0.0.1" or your hostname "ec2-174-129-242-142.compute-1.amazonaws.com"?
Bodo is offline   Reply With Quote
Old 2009-06-24   #7 (permalink)
Junior Member
 
Join Date: May 2009
Posts: 9
Default

thanks this resolved my problem.
lrout is offline   Reply With Quote
Old 2009-06-24   #8 (permalink)
Actian Corp
 
Bodo's Avatar
 
Join Date: Mar 2007
Location: On the OpenROAD
Posts: 2,168
Default

Which one did work?
Did you start the DAS or did you replace "localhost" (with which value)?

Last edited by Bodo; 2009-06-24 at 03:22 AM.
Bodo is offline   Reply With Quote

Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


© 2011 Actian Corporation. All Rights Reserved